Citrix Security Bug

March 5, 2007 at 3:45 pm | Posted in Technical | Leave a comment

If you’re using a Citrix Presentation Server client older than version 10.0, it is time to upgrade.

Citrix announced a security flaw in the older clients, and urges folks to upgrade to circumvent an exploit which has already been found to target the vulnerability.

You can download an updated client here:


TrackBack URI

Blog at
Entries and comments feeds.

%d bloggers like this: